GitHub header

git operations over ssh seeing increased latency on github.com

Incident Report for GitHub

Resolved

From Oct 22, 2025 15:00 UTC to Oct 24, 2025 14:30 UTC git operations via SSH saw periods of increased latency and failed requests, with failure rates ranging from 1.5% to a single spike of 15%. Git operations over http were not affected. This was due to resource exhaustion on our backend ssh servers.

We mitigated the incident by increasing the available resources for ssh connections. We are improving the observability and dynamic scalability of our backend to prevent issues like this in the future.
Posted Oct 24, 2025 - 10:10 UTC

Update

We have found the source of the slowness and mitigated it. We are watching recovery before we status green but no user impact is currently observed.
Posted Oct 24, 2025 - 10:07 UTC

Investigating

We are currently investigating this issue.
Posted Oct 24, 2025 - 09:31 UTC