GitHub header

Incident with using workflow_dispatch for Actions

Incident Report for GitHub

Resolved

On November 1, 2025, between 2:30 UTC and 6:14 UTC, Actions workflows could not be triggered manually from the UI. This impacted all customers queueing workflows from the UI for most of the impact window. The issue was caused by a faulty code change in the UI, which was promptly reverted once the impact was identified. Detection was delayed due to an alerting gap for UI breaks in this area when all underlying APIs are still healthy. We are implementing enhanced alerting and additional automated tests to prevent similar regressions and reduce detection time in the future.
Posted Nov 01, 2025 - 06:14 UTC

Update

Actions is operating normally.
Posted Nov 01, 2025 - 06:14 UTC

Update

We have mitigated the issue for manually dispatching workflows via the UI
Posted Nov 01, 2025 - 06:14 UTC

Update

We have identified the cause of the issue and are working towards a mitigation
Posted Nov 01, 2025 - 05:35 UTC

Update

We are investigating issues manually dispatching workflows via the GitHub UI for Actions. The Workflow Dispatch API is unaffected.
Posted Nov 01, 2025 - 05:05 UTC

Investigating

We are investigating reports of degraded performance for Actions
Posted Nov 01, 2025 - 04:43 UTC
This incident affected: Actions.